I wouldn't go with vb 5. Ugh. hell no. If the site is on 4.2.2, stay there. I'm closing the polls sometime today btw.