WELCOME TO THE NEW PSU FORUMS

Christopher

Community and Technical Manager
Staff member
Jun 1, 2007
11,930
101
63
48
Newnan, GA
#1
At long last, we have new forums here at PSU. I couldn't be more excited. We still have work to do to make this place our own (such as the UI.X branding at the top of the forums). But the hard part is done. So make yourself at home and enjoy!
 

Brandon

Administrator
Staff member
Nov 8, 2004
15,224
113
63
#2
Sup, Chris. Been refreshing this page for days, lol. Glad it's finally up and running. :cool:
 

Brandon

Administrator
Staff member
Nov 8, 2004
15,224
113
63
#4
I'd imagine there were all kinds of goodies when transferring that festering pile that was vB.

"This message is awaiting moderator approval, and is invisible to normal visitors."

^^^

I'm seeing this on every post and it's annoying. o_O
 

Brandon

Administrator
Staff member
Nov 8, 2004
15,224
113
63
#7
It's working now, but that moderator approval message makes me want to gouge out my eyes.

 

Brandon

Administrator
Staff member
Nov 8, 2004
15,224
113
63
#10
I believe I have fixed that, Brandon. This is definitely going to be a work in progress for a bit.
I just set all my permissions to yours in the Admin panel and that helped some things, but yeah the staff permissions (and permissions in general) are going to take some getting used to. o_O

On a positive note, the forums are buttery smooth and fast!
 

Fijiandoce

Administrator
Staff member
Oct 8, 2007
6,447
141
63
#11
I just set all my permissions to yours in the Admin panel and that helped some things, but yeah the staff permissions (and permissions in general) are going to take some getting used to. o_O

On a positive note, the forums are buttery smooth and fast!
Yeah, super smooth!

Having issues with my profile as well, undoubtedly will be the case for most i'd image.
Need to get my sig back up, the_jim hooked me up with that Mirrors Edge sig, can't let it go :(
 

StevenW

General Manager
Staff member
Nov 5, 2008
4,593
37
48
#12
Yeah, super smooth!

Having issues with my profile as well, undoubtedly will be the case for most i'd image.
Need to get my sig back up, the_jim hooked me up with that Mirrors Edge sig, can't let it go :(
I had to approve your post just then for some reason. Hopefully Chris will take a look as soon as he's around!
 

Lethal

Administrator
Staff member
Nov 14, 2007
14,948
312
83
39
#15
I didnt think this was ever going to happen! I don't have a "staff member" icon and my post has to be approved
 

Ghost

Administrator
Staff member
Aug 12, 2009
13,779
297
83
#18
Wow nice!! Writing you a PM Chris, with the ideas I had from yesteryear when this was jus a distant pipedream. :)
 
Likes: StevenW

Vyse

Extreme Poster
Mar 27, 2006
26,816
358
83
#22
Avatars and thread subscriptions (previous User CP) were reset, from what I've noticed so far.
 

Vyse

Extreme Poster
Mar 27, 2006
26,816
358
83
#25
Yeah, good job, guys. Just need to fetch my old avatar and get used to navigating but it's great to see we've finally moved on from vBulletin.